当前位置:安全资讯 >> 全文

英特尔酷睿 CPU 又曝新漏洞 所有操作系统均受影响

发布时间:2018-6-14 18:28 标签: CPU,联网设备
分享到 0

对于英特尔安全而言,今年真是糟糕透顶。先是似乎从未走远的 Meltdown Spectre 漏洞,现在该公司又宣布称发现一个新的涉及“Lazy FP 状态恢复”的推断性执行侧信道漏洞,它可导致恶意程序读取由其它进程使用的数据。

英特尔指出,这个新漏洞 (CVE-2018-3665) 影响所有英特尔酷睿微处理器,它存在于实际 CPU 中,因此无论用户使用的是哪种操作系统如 WindowsLinuxBSD等,只要运行基于英特尔酷睿的 CPU 且使用“Lazy FPU 上下文切换”功能即受影响。

Lazay FPU”是操作系统所使用的一种性能优化功能,它仅保存并恢复 FPU(浮点运算单元)寄存器,后者即CPU 用于必要时存储浮点数的位置。英特尔实际 CPU 中存在一个 bug,可导致另外一个进程访问这些寄存器以及存储在其中的数据。

问题在于,这些浮点数用于执行多种任务,包括加密方程式在内。它可导致攻击者找出更易于破解密钥的数。好在研究人员表示这个漏洞难以通过 web 浏览器被执行,因此它产生的影响要比之前的推断性执行漏洞如Meltdown 要小。

英特尔公司表示该漏洞已在多年前由操作系统和管理程序软件解决。它指出,“这个问题即 Lazy FP 状态恢复和变体 3a 类似。它已由用于很多客户端和数据中心产品中的操作系统和管理程序软件在多年前解决。我们的行业合作伙伴正在更新软件,为仍然受影响的环境解决这个问题,而且预计在未来几周就会发布。我们继续相信协调披露的力量,而且我们对亚马逊德国公司的 Julian StecklinaCyberus Technology GmbH 公司的Thomas PrescherSYSGO AG 公司的Zdenek Sojka Colin Percival 报告这个问题。我们强烈建议其他行业内人士也能遵守协调披露的做法。”

供应商紧急发布安全公告

OpenBSD Dragonfly BSD 公司发布补丁修复人人都在谈论的英特尔漏洞后,关于该 bug 的传言不断。这些安全公告表明,英特尔 CPU FPU 寄存器中可能存在硬件问题,因此供应商决定积极修复操作系统。

好在,该漏洞无需英特尔公司发布新的 CPU 微码,而是可以通过操作系统更新予以修复。由于英特尔已发布安全公告,因此 Linux 的多个发行版本和微软均已发布了和该漏洞相关的安全公告。另外,Redhat也将在未来更新新的处理器修复该漏洞。另外,Redhat 还公布了如何启用 Eager FPU 恢复模式,不过后者并不受漏洞影响。Linux 似乎在2016年在所有的 CPU 上都启用了 Eager FPU 状态恢复。因此,如果用户使用的是更新的 Kernel,那么并不受影响。这个补丁还可向后移植到老旧的受支持版本中。

本文由360代码卫士编译,不代表360观点,转载请注明“转自360代码卫士www.codesafe.cn”。
原文链接:https://www.bleepingcomputer.com/news/security/new-lazy-fp-state-restore-vulnerability-affects-all-intel-core-cpus/
参与讨论,请先 登录 | 注册

用户评论