当前位置:安全资讯 >> 全文

刚刚,WordPress 内容管理系统核心被曝未修复漏洞

发布时间:2018-6-27 19:13 标签: WordPress CMS
分享到 0

今天,RIPS 公司的安全研究员披露了影响组流行的内容管理系统 (CMS) WordPress 的一个未修复漏洞的详情。

研究人员指出在去年11月将漏洞告知 WordPress 团队,但后者迄今为止仍未发布补丁。

该漏洞影响 WordPress CMS 的核心,而非其某个插件或主题。更确切地说,这个漏洞出现在用于删除上传至 WordPress 站点上图片缩略图的 PHP 函数中。

漏洞的严重程度分析

研究人员发现能访问帖子编辑器以及能上传或删除图像(及其缩略图)权限的用户能够将恶意代码插入 WordPress 站点中,导致WordPress CMS 核心的重要文件部分遭删除,而如果无法访问服务器的 FTP 的话,这是不可能发生的。

由于只有拥有某个访问权限级别(作者或更高)的用户才能利用这个漏洞问题,因此它的严重程度大大降低,因为只有这些用户能够创建帖子并管理相关图片和缩略图。

尽管如此,RIPS 专家警告称,如果攻击者能够设法在站点上注册即使是低级别的“用户”账户然后将权限提升的话就能利用该漏洞劫持站点。

之所以能劫持站点是因为该漏洞可导致攻击者删除网站的配置文件 wp-config.php。删除该文件的攻击者能够重新启动安装进程并使用自己的数据库设置安装站点,从而有效地劫持站点传播自定义或恶意内容。研究人员已发布劫持的演示视频。

WordPress 所有版本均受影响

RIPS 指出,这个漏洞影响所有的 WordPress CMS 版本,包括最新版本 v4.9.6

WordPress CMS 团队的发言人并未回复为何未修复该漏洞,不过 Sucuri 公司的联合创始人 Tony Perez 证实了 RIPS 报告的有效性。

由于要求拥有 WordPress 网站作者级别的账户,因此这个漏洞遭大规模利用的可能性并不大。

热修复方案已推出

尽管如此,对于用户基数大的博客和其它 WordPress 站点而言,RIPS 团队已在报告中发布临时的热修复方案

这个热修复方案是网站所有人必须添加到站点目前活跃的主题文件夹中 functions.php 文件中的 PHP 代码。RIPS 团队指出,“所提供的所有 Hotfix 用于挂接到 wp_update_attachement_metadata() 调用中并确保为 meta-value thumb 提供的数据不包含任何可能导致路径遍历的部分。如此,任何和安全相关的文件不被删除。”

本文由360代码卫士编译,不代表360观点,转载请注明“转自360代码卫士www.codesafe.cn”。
原文链接:https://www.bleepingcomputer.com/news/security/unpatched-flaw-disclosed-in-wordpress-cms-core/
参与讨论,请先 登录 | 注册

用户评论